<!DOCTYPE html>
<meta http-equiv="X-UA-Compatible" content="IE=9">
<script type="text/javascript" src="//use.typekit.net/yop0pnm.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=Edge;chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11"/>
<link rel="stylesheet" href="http://www.thecompassnews.org/wp-content/themes/TheCompass/columnal.css" type="text/css" media="screen"/>
 
<!--[if lt IE 9]>
    		<link rel="stylesheet" href="http://www.thecompassnews.org/wp-content/themes/TheCompass/ie.css" type="text/css" media="screen" />
		<![endif]-->
 
<link rel="stylesheet" href="http://www.thecompassnews.org/wp-content/themes/TheCompass/custom.css" type="text/css" media="screen"/>
<link rel="pingback" href="http://www.thecompassnews.org/xmlrpc.php"/>
<!--[if lt IE 9]>
<script src="http://www.thecompassnews.org/wp-content/themes/TheCompass/js/html5.js" type="text/javascript"></script>
<![endif]-->
 
<title>After SNAP president resigns, new generation of leadership eyed | The Compass</title>
<link rel="canonical" href="http://www.thecompassnews.org/2017/02/snap-president-resigns-new-generation-leadership-eyed/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="After SNAP president resigns, new generation of leadership eyed | The Compass"/>
<meta property="og:description" content="WASHINGTON &#8212; The resignation of the president of the Survivors Network of Those Abused by Priests opens the door for a new generation of leaders, said a"/>
<meta property="og:url" content="http://www.thecompassnews.org/2017/02/snap-president-resigns-new-generation-leadership-eyed/"/>
<meta property="og:site_name" content="The Compass"/>
<meta property="article:publisher" content="https://www.facebook.com/TheCompassNews"/>
<meta property="article:section" content="Nation and World"/>
<meta property="article:published_time" content="2017-02-07T12:44:43-06:00"/>
<meta property="og:image" content="http://www.thecompassnews.org/wp-content/uploads/2015/02/JU-sx1b1.jpeg"/>
 
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="The Compass &raquo; Feed" href="http://www.thecompassnews.org/feed/"/>
<link rel="alternate" type="application/rss+xml" title="The Compass &raquo; Comments Feed" href="http://www.thecompassnews.org/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="The Compass &raquo; After SNAP president resigns, new generation of leadership eyed Comments Feed" href="http://www.thecompassnews.org/2017/02/snap-president-resigns-new-generation-leadership-eyed/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.thecompassnews.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='icon-font-style-css' href='http://www.thecompassnews.org/wp-content/plugins/mnky-vector-icons/css/icon-font-style.css' type='text/css' media='all'/>
<link rel='stylesheet' id='anpn-style-css' href='http://www.thecompassnews.org/wp-content/plugins/advanced-post-navigator/public/anpn-css.css?ver=4.7.2' type='text/css' media='all'/>
<link rel='stylesheet' id='default-template-css' href='http://www.thecompassnews.org/wp-content/plugins/really-simple-twitter-feed-widget/extension/readygraph/assets/css/default-popup.css?ver=4.7.2' type='text/css' media='all'/>
<link rel='stylesheet' id='sp_printPage_lightbox-css' href='http://www.thecompassnews.org/wp-content/plugins/syndicate-press/css/TinyLightbox.css?ver=1.00' type='text/css' media=''/>
<link rel='stylesheet' id='ubermenu-basic-css' href='http://www.thecompassnews.org/wp-content/plugins/ubermenu/standard/styles/basic.css?ver=2.4.0.3' type='text/css' media='all'/>
<link rel='stylesheet' id='wordpress-popular-posts-css' href='http://www.thecompassnews.org/wp-content/plugins/wordpress-popular-posts/style/wpp.css?ver=3.3.4' type='text/css' media='all'/>
<link rel='stylesheet' id='tablepress-default-css' href='http://www.thecompassnews.org/wp-content/tablepress-combined.min.css?ver=6' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://www.thecompassnews.org/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.2' type='text/css' media='all'/>
<link rel='stylesheet' id='A2A_SHARE_SAVE-css' href='http://www.thecompassnews.org/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.13' type='text/css' media='all'/>
<link rel='stylesheet' id='uds-billboard-css' href='http://www.thecompassnews.org/wp-content/plugins/uBillboard/css/billboard.min.css?ver=3.5.2' type='text/css' media='screen'/>
 
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-6574869-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');

</script>
 
<script type='text/javascript' src='http://www.thecompassnews.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-content/plugins/adrotate-pro/library/jquery.clicktracker.js?ver=0.6'></script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-content/plugins/advanced-post-navigator/public/anpn-js.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-content/plugins/advanced-iframe/js/ai.js?ver=280000'></script>
<link rel='https://api.w.org/' href='http://www.thecompassnews.org/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.thecompassnews.org/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.thecompassnews.org/wp-includes/wlwmanifest.xml"/>
<link rel='shortlink' href='http://www.thecompassnews.org/?p=28957'/>
<link rel="alternate" type="application/json+oembed" href="http://www.thecompassnews.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.thecompassnews.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&#038;format=xml"/>
<script type="text/javascript">
var a2a_config=a2a_config||{};a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.templates=a2a_config.templates||{};
</script>
<script type="text/javascript" src="http://static.addtoany.com/menu/page.js" async="async"></script>
 
 
<script type="text/javascript">
var tracker_url = 'http://www.thecompassnews.org/wp-content/plugins/adrotate-pro/library/clicktracker.php';
</script>
 
<!--[if lte IE 7]>
			<link href="http://www.thecompassnews.org/wp-content/plugins/mnky-vector-icons/css/ie7.min.css" media="screen" rel="stylesheet" type="text/css">
		<![endif]-->
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style>  
<script type="text/javascript">

					var sampling_active = 0;
					var sampling_rate   = 100;
					var do_request = false;

					if ( !sampling_active ) {
						do_request = true;
					} else {
						var num = Math.floor(Math.random() * sampling_rate) + 1;
						do_request = ( 1 === num );
					}

					if ( do_request ) {

						/* Create XMLHttpRequest object and set variables */
						var xhr = ( window.XMLHttpRequest )
						  ? new XMLHttpRequest()
						  : new ActiveXObject( "Microsoft.XMLHTTP" ),
						url = 'http://www.thecompassnews.org/wp-admin/admin-ajax.php',
						params = 'action=update_views_ajax&token=1dfe85a61c&wpp_id=28957';
						/* Set request method and target URL */
						xhr.open( "POST", url, true );
						/* Set request header */
						xhr.setRequestHeader( "Content-type", "application/x-www-form-urlencoded" );
						/* Hook into onreadystatechange */
						xhr.onreadystatechange = function() {
							if ( 4 === xhr.readyState && 200 === xhr.status ) {
								if ( window.console && window.console.log ) {
									window.console.log( xhr.responseText );
								}
							}
						};
						/* Send request */
						xhr.send( params );

					}

				</script>
 
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.thecompassnews.org/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="icon" href="http://www.thecompassnews.org/wp-content/uploads/2016/07/compass-icon.png" sizes="32x32"/>
<link rel="icon" href="http://www.thecompassnews.org/wp-content/uploads/2016/07/compass-icon.png" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="http://www.thecompassnews.org/wp-content/uploads/2016/07/compass-icon.png"/>
<meta name="msapplication-TileImage" content="http://www.thecompassnews.org/wp-content/uploads/2016/07/compass-icon.png"/>
 
<style type="text/css" id="ubermenu-style-generator-css">#megaMenu .ss-nav-menu-with-img>a>.wpmega-link-title,#megaMenu .ss-nav-menu-with-img>a>.wpmega-link-description,#megaMenu .ss-nav-menu-with-img>a>.wpmega-item-description,#megaMenu .ss-nav-menu-with-img>span.um-anchoremulator>.wpmega-link-title,#megaMenu .ss-nav-menu-with-img>span.um-anchoremulator>.wpmega-link-description,#megaMenu .ss-nav-menu-with-img>span.um-anchoremulator>.wpmega-item-description{padding-left:23px;}</style>
 
<noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1;}</style></noscript>
</head>
<body class="post-template-default single single-post postid-28957 single-format-standard singular two-column right-sidebar wpb-js-composer js-comp-ver-5.0.1 vc_responsive">
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-6574869-1");
pageTracker._trackPageview();
} catch(err) {}</script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=214533701976308";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="container header ">
<div class="row masthead" style="overflow: visible;">
<div class="col_8 logo_container">
<a class="site_logo" href="http://www.thecompassnews.org"><img src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/site-logo.png" alt=""></a>
<a class="mobile_logo" href="http://www.thecompassnews.org"><img src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/mobile_logo.jpg" alt=""></a>
</div> 
<div class="col_4 last site_tools no-padding-mobile">
<div class="col_12 no-padding-mobile">
<div class="toolbox">
<div class="padding">
<ul class="housekeeping-two">
<li><a href="/advertise/">Advertise</a></li>
<li><a href="/subscribe/">Subscribe</a></li>
</ul>
<ul class="housekeeping">
<li><a href="/contact/">Contact</a></li>
<li><a href="/sitemap/">Sitemap</a></li>
<li class="mobile_only"><a href="/advertise/">Advertise</a></li>
<li class="mobile_only"><a href="/subscribe/">Subscribe</a></li>
</ul>
<ul class="social_icons">
<li><a target="_blank" href="https://twitter.com/thecompassnews"><img src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/new-icon-twitter.png" alt="" width="28" height="28"></a></li>
<li><a target="_blank" href="https://www.facebook.com/TheCompassNews"><img src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/new-icon-facebook.png" alt="" width="28" height="28"></a></li>
<li><a target="_blank" href="http://pinterest.com/thecompassnews/"><img src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/new-icon-pinterest.png" alt="" width="28" height="28"></a></li>
<li><a target="_blank" href="https://instagram.com/thecompassnews"><img src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/new-icon-instagram.png" alt="" width="28" height="28"></a></li>
<li><a target="_blank" href="http://thecompassnews.tumblr.com/"><img src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/new-icon-tumblr.png" alt="" width="28" height="28"></a></li>
<li><a target="_blank" href="http://feeds.feedburner.com/TheCompassOfficialNewspaperOfTheDioceseOfGreenBay"><img src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/new-icon-rss.png" alt="" width="28" height="28"></a></li>
</ul>
</div> 
</div> 
</div> 
<div class="col_12">
<div class="header_ad_space">
<a data-track="NDYsMSwwLDE=" class="gofollow" href="http://www.mccormickassistedliving.com/" target="_blank"><img src="http://www.thecompassnews.org/wp-content/uploads/2015/05/McCormick300x90-05-01-15.jpg"/></a> </div> 
</div> 
</div> 
<div class="col_12 nav_wrapper">
<div id="megaMenu" class="megaMenuContainer megaMenu-nojs megaMenuHorizontal megaResponsive megaResponsiveToggle wpmega-withjs megaMenuOnHover megaFullWidth wpmega-noconflict megaMinimizeResiduals megaResetStyles themeloc-primary"><div id="megaMenuToggle" class="megaMenuToggle">Menu&nbsp; <span class="megaMenuToggle-icon"></span></div><ul id="megaUber" class="megaMenu"><li id="menu-item-7485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home ss-nav-menu-item-0 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="http://www.thecompassnews.org/"><span class="wpmega-link-title"><i class="moon-home custom-nav-icon"></i></span></a></li><li id="menu-item-7528" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children mega-with-sub ss-nav-menu-item-1 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="#"><span class="wpmega-link-title">News</span></a>
<ul class="sub-menu sub-menu-1">
<li id="menu-item-7451" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/news/local/"><span class="wpmega-link-title">Local</span></a></li><li id="menu-item-7452" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/news/nation-and-world/"><span class="wpmega-link-title">Nation and World</span></a>
<ul class="sub-menu sub-menu-2">
<li id="menu-item-8721" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-2"><a href="http://www.thecompassnews.org/catholic-news-service/"><span class="wpmega-link-title">Catholic News Service</span></a></li> </ul>
</li><li id="menu-item-7454" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/news/espanol/"><span class="wpmega-link-title">Español</span></a></li></ul>
</li><li id="menu-item-7529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children mega-with-sub ss-nav-menu-item-2 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="#"><span class="wpmega-link-title">Faith</span></a>
<ul class="sub-menu sub-menu-1">
<li id="menu-item-7455" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/faith/saint-day/"><span class="wpmega-link-title">Saint of the Day</span></a></li><li id="menu-item-7456" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/faith/foundations/"><span class="wpmega-link-title">Foundations of Faith</span></a></li></ul>
</li><li id="menu-item-7530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children mega-with-sub ss-nav-menu-item-3 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="#"><span class="wpmega-link-title">Columnists</span></a>
<ul class="sub-menu sub-menu-1">
<li id="menu-item-7457" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/columnists/bishopscorner/"><span class="wpmega-link-title">Bishop&#8217;s Corner</span></a></li><li id="menu-item-7459" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/columnists/editorials/"><span class="wpmega-link-title">Editorials</span></a></li><li id="menu-item-7461" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/columnists/opinions/"><span class="wpmega-link-title">Opinion</span></a></li><li id="menu-item-7462" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/columnists/sunday-readings/"><span class="wpmega-link-title">Sunday Readings</span></a></li><li id="menu-item-7460" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/columnists/living-rite/"><span class="wpmega-link-title">Living Rite</span></a></li><li id="menu-item-7458" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/columnists/compass-on-campas/"><span class="wpmega-link-title">Compass on Campus</span></a></li></ul>
</li><li id="menu-item-7532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children mega-with-sub ss-nav-menu-item-4 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="#"><span class="wpmega-link-title">Features</span></a>
<ul class="sub-menu sub-menu-1">
<li id="menu-item-7463" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/features/your-catholic-neighbor-s8-features/"><span class="wpmega-link-title">Your Catholic Neighbor</span></a></li><li id="menu-item-7467" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/features/c54-kids-page/"><span class="wpmega-link-title">Kids&#8217; Page</span></a></li><li id="menu-item-7807" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/support-our-advertisers/"><span class="wpmega-link-title">Support Our Advertisers</span></a></li><li id="menu-item-7658" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/submit-obituaries/"><span class="wpmega-link-title">Submit Obituaries</span></a></li><li id="menu-item-7654" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/submit-anniversaries/"><span class="wpmega-link-title">Submit Anniversaries</span></a></li><li id="menu-item-10946" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/just-kids/"><span class="wpmega-link-title">Just For Kids</span></a></li><li id="menu-item-17274" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/features/pilgrimages/"><span class="wpmega-link-title">Pilgrimages</span></a></li></ul>
</li><li id="menu-item-7533" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children mega-with-sub ss-nav-menu-item-5 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="#"><span class="wpmega-link-title">Web Extras</span></a>
<ul class="sub-menu sub-menu-1">
<li id="menu-item-19613" class="menu-item menu-item-type-custom menu-item-object-custom ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/2014/04/mass-schedules-2/"><span class="wpmega-link-title">Mass Schedules</span></a></li><li id="menu-item-19576" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/compass-bulletin/"><span class="wpmega-link-title">The Compass in the Bulletin</span></a></li><li id="menu-item-9576" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/employment-opportunities/"><span class="wpmega-link-title">Employment Listings</span></a></li><li id="menu-item-7950" class="menu-item menu-item-type-post_type menu-item-object-post ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/2013/08/parish-bulletin-inserts-2/"><span class="wpmega-link-title">Parish Bulletin Inserts</span></a></li><li id="menu-item-7473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/web-extras/compass-classroom-page/"><span class="wpmega-link-title">Compass in the Classroom</span></a>
<ul class="sub-menu sub-menu-2">
<li id="menu-item-8601" class="menu-item menu-item-type-post_type menu-item-object-post ss-nav-menu-item-depth-2"><a href="http://www.thecompassnews.org/2016/05/the-compass-in-the-classroom-2/"><span class="wpmega-link-title">What is Compass in the Classroom?</span></a></li><li id="menu-item-8556" class="menu-item menu-item-type-post_type menu-item-object-post ss-nav-menu-item-depth-2"><a href="http://www.thecompassnews.org/2016/05/faqs-why-use-compass-in-the-classroom/"><span class="wpmega-link-title">FAQs: Why use Compass in the Classroom?</span></a></li><li id="menu-item-8554" class="menu-item menu-item-type-post_type menu-item-object-post ss-nav-menu-item-depth-2"><a href="http://www.thecompassnews.org/2015/05/registration-form-2011-2012/"><span class="wpmega-link-title">2016-17 Compass in the Classroom Registration Form</span></a></li><li id="menu-item-18114" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-2"><a href="http://www.thecompassnews.org/compass-teacher-worksheets/"><span class="wpmega-link-title">Compass Teacher Worksheets</span></a></li> </ul>
</li></ul>
</li><li id="menu-item-7573" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children mega-with-sub ss-nav-menu-item-6 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="#"><span class="wpmega-link-title">Reviews</span></a>
<ul class="sub-menu sub-menu-1">
<li id="menu-item-7561" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/reviews/book-reviews/"><span class="wpmega-link-title">Book Reviews</span></a></li><li id="menu-item-7562" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/reviews/movie-reviews/"><span class="wpmega-link-title">Movie Reviews</span></a></li><li id="menu-item-7563" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/category/reviews/video-game-reviews/"><span class="wpmega-link-title">Video Game Reviews</span></a></li></ul>
</li><li id="menu-item-7543" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children mega-with-sub ss-nav-menu-item-7 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="#"><span class="wpmega-link-title">Multimedia</span></a>
<ul class="sub-menu sub-menu-1">
<li id="menu-item-8777" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/multimedia/slideshows/"><span class="wpmega-link-title">Slideshows</span></a></li><li id="menu-item-7592" class="menu-item menu-item-type-custom menu-item-object-custom ss-nav-menu-item-depth-1"><a href="http://www.flickr.com/photos/thecompass/" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.flickr.com/photos/thecompass/', 'Photos');" target="_blank"><span class="wpmega-link-title">Photos</span></a></li><li id="menu-item-7593" class="menu-item menu-item-type-custom menu-item-object-custom ss-nav-menu-item-depth-1"><a href="http://www.youtube.com/TheCompassNews" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.youtube.com/TheCompassNews', 'Video');" target="_blank"><span class="wpmega-link-title">Video</span></a></li><li id="menu-item-7810" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-depth-1"><a href="http://www.thecompassnews.org/cns-video/"><span class="wpmega-link-title">CNS Video</span></a></li></ul>
</li><li id="menu-item-7547" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-8 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="http://www.thecompassnews.org/calendar-2/"><span class="wpmega-link-title">Calendar</span></a></li><li id="menu-item-7546" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-9 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="http://www.thecompassnews.org/archives/"><span class="wpmega-link-title">Archives</span></a></li><li id="menu-item-8384" class="menu-item menu-item-type-taxonomy menu-item-object-category ss-nav-menu-item-10 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="http://www.thecompassnews.org/category/compassblog/"><span class="wpmega-link-title">Blog</span></a></li><li id="menu-item-7483" class="menu-item menu-item-type-post_type menu-item-object-page ss-nav-menu-item-11 ss-nav-menu-item-depth-0 ss-nav-menu-reg um-flyout-align-center"><a href="http://www.thecompassnews.org/diocese/"><span class="wpmega-link-title">Diocese of Green Bay</span></a></li></ul></div> <div class="clear"></div>
</div> 
</div> 
</div> 
<div class="container">
<div class="row" style="overflow:visible;">
<div class="page_content">
<div id="primary">
<div id="content" role="main">
<div class="col_8">
<div class="row">
<div class="slider_ad_container">
<a data-track="NDgsMywwLDE=" class="gofollow" href="http://fscc-calledtobe.org/" target="_blank"><img src="http://www.thecompassnews.org/wp-content/uploads/2017/01/FSCC_728x90_012617.gif"/></a> </div> 
<article id="post-28957" class="post-28957 post type-post status-publish format-standard hentry category-nation-and-world">
<header class="entry-header">
<h1 class="entry-title"><a href="http://www.thecompassnews.org/2017/02/snap-president-resigns-new-generation-leadership-eyed/" title="Permalink to After SNAP president resigns, new generation of leadership eyed" rel="bookmark">After SNAP president resigns, new generation of leadership eyed</a></h1>
<p class="post-subhead" style="display: none;"></p>
<div class="entry-meta">
<p class="author">By Dennis Sadowski | Catholic News Service <br/>February 7, 2017</p>
</div> 
</header> 
<h3></h3>
<div class="entry-content">
 
 
<div class="addtoany_share_save_container addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://www.thecompassnews.org/2017/02/snap-president-resigns-new-generation-leadership-eyed/" data-a2a-title="After SNAP president resigns, new generation of leadership eyed"><a href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_facebook" title="Facebook" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_twitter" title="Twitter" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_google_plus" title="Google+" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_tumblr" title="Tumblr" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_pinterest" title="Pinterest" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_email" title="Email" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/printfriendly?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/printfriendly?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_printfriendly" title="PrintFriendly" rel="nofollow" target="_blank"></a><a href="https://www.addtoany.com/share" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.addtoany.com/share', '');" class="a2a_dd addtoany_share_save"></a></div></div><p>WASHINGTON &#8212; The resignation of the president of the Survivors Network of Those Abused by Priests opens the door for a new generation of leaders, said a top volunteer within the organization.</p>
<p>&#8220;SNAP is full of vibrant leaders,&#8221; Joelle Casteix, the organization&#8217;s Western regional director, told Catholic News Service Feb. 6. She said the resignation Feb. 3 of Barbara Blaine, who founded SNAP and served as its president for 29 years, was not totally unexpected.</p>
<p>&#8220;The time was not what anyone had planned, but any vibrant organization can always find people to stand up and lead an organization into its next phase,&#8221; Casteix said.</p>
<p>&#8220;For us, it&#8217;s always heartbreaking when a leader departs,&#8221; she added. &#8220;The true heart and mission of SNAP will always be with its volunteer leadership.&#8221;</p>
<p>Blaine&#8217;s resignation was announced to SNAP&#8217;s volunteer members Feb. 4. Mary Ellen Kruger, who chairs the SNAP board of directors, said in an email Feb. 6 to CNS that Blaine stepped down for personal reasons &#8220;that have nothing to do with the lawsuit.&#8221;</p>
<p>The action came less than three weeks after a former SNAP director of development, Gretchen Rachel Hammond, filed a wrongful termination lawsuit charging that the organization is more interested in fundraising and taking kickbacks from lawyers suing the Catholic Church than in helping survivors.</p>
<p>Blaine had been a vocal critic of organizations, particularly the Catholic Church, for responses to clergy sexual abuse. She often was joined by David Clohessy, SNAP&#8217;s former longtime executive director, who resigned Dec. 31.</p>
<p>Religion News Service reported Jan. 24 that Clohessy said his decision was unrelated to the lawsuit. &#8220;My last day was five weeks ago, before this lawsuit ever happened,&#8221; he told RNS. The suit was filed Jan. 17. In response to an email query from CNS to confirm that information Jan. 26, Blaine said: &#8220;David resigned Dec. 31, 2016, and it had nothing to do with the lawsuit.&#8221;</p>
<p>SNAP is considered the largest and best-known advocacy organization for survivors of clerical abuse.</p>
<p>Hammond&#8217;s lawsuit, filed in Cook County Circuit Court in Chicago, accuses SNAP of being &#8220;a commercial organization&#8221; and &#8220;premised upon farming out abuse survivors as clients for attorneys, who then file lawsuits on behalf of the survivors and collect settlement checks from the Catholic Church.&#8221;</p>
<p>Hammond worked for SNAP from July 2011 to February 2013. She claims she was fired in retaliation for a series of discoveries she made about the way settlements were being handled, and that the stress caused by SNAP&#8217;s treatment of her sent her to the hospital four times and resulted in a series of health problems.</p>
<p>The lawsuit also asserted that SNAP &#8220;is motivated by its directors&#8217; and officers&#8217; personal and ideological animus against the Catholic Church.&#8221; In 2011, SNAP helped publicize an attempt in Europe to bring charges in the International Criminal Court against Pope Benedict XVI and other Vatican officials for crimes against humanity for allegedly &#8220;concealing and tolerating&#8221; clergy abuse. In June 2013, the head of that court declined to pursue such a case.</p>
<p>On Feb. 1, Kruger addressed the lawsuit&#8217;s charges on the organization&#8217;s website. She said SNAP had never been a counseling organization, but rather a volunteer-based, peer support network of survivors who help each other through a variety of actions and in local groups in 22 states.</p>
<p>Kruger also acknowledged that SNAP refers abuse survivors to attorneys &#8220;in an effort to bring accountability to those that have condoned and perpetuated this abuse for decades.&#8221; She said if abuse survivors are unable to &#8220;fight back against the system, systemic abuse of authority would continue unabated.&#8221;</p>
<p>The statement denied that SNAP ever refers survivors to attorneys in exchange for money, saying that the organization &#8220;has never and will never enter into any &#8216;kickback schemes.'&#8221; Kruger&#8217;s statement acknowledged that SNAP solicits and accepts donations from &#8220;anyone who believes in our cause,&#8221; including attorneys who have filed lawsuits against priests and particular dioceses.</p>
<p>While tax filings with the IRS showed Blaine and Clohessy were paid $86,320 each in 2014, the latest year records are available, Casteix told CNS she would like to see the organization &#8220;move into professional leadership.&#8221;</p>
<p>&#8220;I believe that SNAP&#8217;s next phase can be much more inclusive of survivors &#8230; and have professional leadership to reach out to a broader range of survivors,&#8221; she said.</p>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class="addtoany_share_save_container addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://www.thecompassnews.org/2017/02/snap-president-resigns-new-generation-leadership-eyed/" data-a2a-title="After SNAP president resigns, new generation of leadership eyed"><a href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_facebook" title="Facebook" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_twitter" title="Twitter" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_google_plus" title="Google+" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_tumblr" title="Tumblr" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_pinterest" title="Pinterest" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_email" title="Email" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/printfriendly?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/printfriendly?linkurl=http%3A%2F%2Fwww.thecompassnews.org%2F2017%2F02%2Fsnap-president-resigns-new-generation-leadership-eyed%2F&amp;linkname=After%20SNAP%20president%20resigns%2C%20new%20generation%20of%20leadership%20eyed', '');" class="a2a_button_printfriendly" title="PrintFriendly" rel="nofollow" target="_blank"></a><a href="https://www.addtoany.com/share" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.addtoany.com/share', '');" class="a2a_dd addtoany_share_save"></a></div></div>
 
<div class="clear"></div>
<div class="above_related_posts_container">
  </div> 
</div> 
<footer class="entry-meta" style="display: none;">
This entry was posted in <a href="http://www.thecompassnews.org/category/news/nation-and-world/" rel="category tag">Nation and World</a> by <a href="http://www.thecompassnews.org/author/patricia-kasten/">Patricia Kasten</a>. Bookmark the <a href="http://www.thecompassnews.org/2017/02/snap-president-resigns-new-generation-leadership-eyed/" title="Permalink to After SNAP president resigns, new generation of leadership eyed" rel="bookmark">permalink</a>.
</footer> 
</article> 
<div id="disqus_thread">
</div>
<script type="text/javascript">
var disqus_url = 'http://www.thecompassnews.org/2017/02/snap-president-resigns-new-generation-leadership-eyed/';
var disqus_identifier = '28957 http://www.thecompassnews.org/?p=28957';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'thecompassnews';
var disqus_title = "After SNAP president resigns, new generation of leadership eyed";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=28957';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
</div> 
</div> 
<div class="col_4 last">
<div id="secondary" class="widget-area" role="complementary">
<aside id="enhancedtextwidget-5" class="mobile_hide widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><div class="col_6 mobile_hide">
<a class="donate green_button" href="/donate/">Donate</a>
</div> 
<div class="col_6 last  mobile_hide">
<form role="search" method="get" class="searchbox" id="searchform" action="http://www.thecompassnews.org/">
<input type="text" value="Search" onclick="this.value='';" onfocus="this.select()" onblur="this.value=!this.value?'Search':this.value;" value="Search" name="s" id="s"/>
</form>
</div> 
<div class="clear"></div></div></aside><aside id="enhancedtextwidget-2" class="bishop-corner widget widget_text enhanced-text-widget"><h3 class="widget-title">Bishop&#8217;s Corner</h3><div class="textwidget widget-text">
<div class="bishop-corner-content">
<a href="http://www.thecompassnews.org/2017/02/bishops-appeal-inspiring-disciples/" class="bishop-title">Bishop’s Appeal: Inspiring disciples</a>
<img class="blogger_photo_category_page" src="http://www.thecompassnews.org/wp-content/uploads/2013/11/Bishop-Ricken5-2013.jpg"/>
<span class="bishop-excerpt"><p>When I was 7 years old, most of my friends knew what they wanted to be when they grew up. For me, this moment came at Mass. &hellip; <a href="http://www.thecompassnews.org/2017/02/bishops-appeal-inspiring-disciples/"><span class="readmore">Read More</span></a></p>
</span>
</div> 
</div></aside><aside id="adrotate_widgets-2" class="widget widget_adrotate_widgets"><a data-track="NDUsNCwwLDE=" class="gofollow" href="http://www.becomingasister.org/" target="_blank"><img src="http://www.thecompassnews.org/wp-content/uploads/2015/03/SrsSorrowfulMother_Vocations-01-20151.jpg"/></a></aside>
 
<aside id="wpp-2" class="widget popular-posts">
<h3 class="widget-title">Popular Posts</h3>
<ul class="wpp-list">
<li><a href="http://www.thecompassnews.org/2017/02/fr-nowakowski-93-dies-youth-served-cubs-bat-boy/" title="Fr. Nowakowski, 93, dies; as youth served as Cubs bat boy" class="wpp-post-title" target="_self">Fr. Nowakowski, 93, dies; as youth served as Cubs bat boy</a> </li>
<li><a href="http://www.thecompassnews.org/2017/02/vatican-releases-updated-guidelines-bioethical-questions/" title="Vatican releases updated guidelines for bioethical questions" class="wpp-post-title" target="_self">Vatican releases updated guidelines for bioethical questions</a> </li>
<li><a href="http://www.thecompassnews.org/2017/01/trump-action-halts-refugee-families-resettlement-charlotte-diocese/" title="Trump action halts refugee families&#8217; resettlement in Charlotte Diocese" class="wpp-post-title" target="_self">Trump action halts refugee families&#8217; resettlement in Charlotte Diocese</a> </li>
<li><a href="http://www.thecompassnews.org/2017/02/st-john-homeless-shelter-recipient-local-youths-eagle-scout-project/" title="St. John Homeless Shelter is recipient of local youth’s Eagle Scout project" class="wpp-post-title" target="_self">St. John Homeless Shelter is recipient of local youth’s Eagle Scout project</a> </li>
<li><a href="http://www.thecompassnews.org/2017/02/accused-priest-killers-case-bishops-urge-mercy-reject-death-penalty/" title="In accused priest killer&#8217;s case, bishops urge mercy, reject death penalty" class="wpp-post-title" target="_self">In accused priest killer&#8217;s case, bishops urge mercy, reject death penalty</a> </li>
</ul>
</aside>
 
<aside id="adrotate_widgets-3" class="widget widget_adrotate_widgets"> 
<script src="//ads.catholicadnet.com/au/"></script>
<ins class="CANDisplayAD" data-ad-unit="548220160104T1159532804633BAC6BDA94EC4959661C5972302F6" style="display:block"></ins>
 </aside><aside id="enhancedtextwidget-3" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><div class="fb-like-box" data-href="http://www.facebook.com/TheCompassNews" data-width="292" data-show-faces="true" data-stream="true" data-show-border="false" data-header="true"></div></div></aside><aside id="adrotate_widgets-4" class="widget widget_adrotate_widgets"> 
<script src="//ads.catholicadnet.com/au/"></script>
<ins class="CANDisplayAD" data-ad-unit="548220160104T1159532804633BAC6BDA94EC4959661C5972302F6" style="display:block"></ins>
 </aside><aside id="advanced_text-2" class="widget advanced_text"><div class='AdvancedText'><a class="twitter-timeline" href="https://twitter.com/thecompassnews" data-widget-id="364792673330143233">Tweets by @thecompassnews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div></aside>
<aside id="enhancedtextwidget-4" class="mobile_hide widget widget_text enhanced-text-widget"><div class="textwidget widget-text"> <object height="375" width="500" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=10,0,32,18" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000">
<param name="wmode" value="opaque"/>
<param name="allowScriptAccess" value="always"/>
<param name="allowFullScreen" value="true"/>
<param name="flashvars" value="target=_self&f_l=f&f_fscr=t&f_tb=t&f_bb=t&f_bbl=f&f_fss=f&f_2up=t&f_crp=t&f_wm=t&f_s2f=t&f_emb=t&f_cap=t&f_sln=t&imgT=f&cred=f&trans=xfade&f_link=f&f_smooth=f&f_mtrx=t&tbs=5000&f_ap=t&f_up=f&btype=old&bcolor=%23CCCCCC"/>
<param name="src" value="http://www.photoshelter.com/swf/CSlideShow.swf?feedSRC=http%3A//samlucero.photoshelter.com/gallery/Where-in-the-World-is-The-Compass/G0000c.hSHM4Rmrc%3Ffeed%3Djson"/><embed height="375" width="500" src="http://www.photoshelter.com/swf/CSlideShow.swf?feedSRC=http%3A//samlucero.photoshelter.com/gallery/Where-in-the-World-is-The-Compass/G0000c.hSHM4Rmrc%3Ffeed%3Djson" flashvars="target=_self&f_l=f&f_fscr=t&f_tb=t&f_bb=t&f_bbl=f&f_fss=f&f_2up=t&f_crp=t&f_wm=t&f_s2f=t&f_emb=t&f_cap=t&f_sln=t&imgT=f&cred=f&trans=xfade&f_link=f&f_smooth=f&f_mtrx=t&tbs=5000&f_ap=t&f_up=f&btype=old&bcolor=%23CCCCCC" allowfullscreen="true" allowscriptaccess="always" wmode="opaque" type="application/x-shockwave-flash"></embed><span name="flashvars" value="target=_self&f_l=f&f_fscr=t&f_tb=t&f_bb=t&f_bbl=f&f_fss=f&f_2up=t&f_crp=t&f_wm=t&f_s2f=t&f_emb=t&f_cap=t&f_sln=t&imgT=f&cred=f&trans=xfade&f_link=f&f_smooth=f&f_mtrx=t&tbs=5000&f_ap=t&f_up=f&btype=old&bcolor=%23CCCCCC"></span>
</object><p style="font-size:11px;">Readers are invited to send us their photo holding a copy of The Compass. Send digital photos to <a href="mailto:compassnews@gbdioc.org">this link</a>.</p></div></aside><aside id="adrotate_widgets-5" class="widget widget_adrotate_widgets"> 
<script src="//ads.catholicadnet.com/au/"></script>
<ins class="CANDisplayAD" data-ad-unit="548220160104T1159532804633BAC6BDA94EC4959661C5972302F6" style="display:block"></ins>
 </aside><aside id="advanced_text-3" class="widget advanced_text"><div class='AdvancedText'><div class="small_sidebar_ad_container left_small_ad">
<a data-track="MzUsOCwwLDE=" class="gofollow" href="http://www.gbdioc.org/whoarewe/diocesan-facilities/29-cemeteries.html" target="_blank"><img src="http://www.thecompassnews.org/wp-content/uploads/2015/03/AllouezRightSmallTileMay2014.gif"/></a></div> 
<div class="small_sidebar_ad_container">
<a data-track="NDcsOSwwLDE=" class="gofollow" href="http://www.norbertines.org/" target="_blank"><img src="http://www.thecompassnews.org/wp-content/uploads/2015/03/StNorbertAbbeyWinter2015web.jpg"/></a></div> 
<div class="small_sidebar_ad_container left_small_ad">
<a data-track="MzYsMTAsMCwx" class="gofollow" href="http://www.thecompassnews.org/subscribe/" target="_blank"><img src="http://www.thecompassnews.org/wp-content/uploads/2015/03/right-small-tile-anytime-anywhere.jpg"/></a></div> 
<div class="small_sidebar_ad_container">
<a data-track="NDEsMTEsMCwx" class="gofollow" href="http://www.thecompassnews.org/subscribe/"><img src="http://www.thecompassnews.org/wp-content/uploads/2015/03/advertisehere.jpg"/></a></div> </div></aside>
</div> 
<div class="small_sidebar_ad_container left_small_ad">
</div> 
<div class="small_sidebar_ad_container">
</div> 
<div class="small_sidebar_ad_container left_small_ad">
</div> 
<div class="small_sidebar_ad_container">
</div> 
</div> 
</div> 
</div> 
<div class="clear"></div>
<div class="footer_ad_container">
<a data-track="NTcsMTQsMCwx" class="gofollow" href="http://www.thecompassnews.org/subscribe/" target="_blank"><img src="http://www.thecompassnews.org/wp-content/uploads/2016/07/the-compass_subscribe-now_web-ad_970x90.jpg"/></a></div> 
</div> 
</div> 
</div> 
<div class="container footer">
<div class="padding">
<div class="row" style="padding-right: 0; padding-left: 0;">
<div class="col_12">
<div class="col_4">
<img class="footer_logo" src="http://www.thecompassnews.org/wp-content/themes/TheCompass/images/site-footer-logo.png"/></div> 
<div class="col_8 last">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-126" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-126"><a href="http://www.thecompassnews.org/">Home</a></li>
<li id="menu-item-8337" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8337"><a href="http://www.thecompassnews.org/category/news/local/">News</a></li>
<li id="menu-item-8338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8338"><a href="http://www.thecompassnews.org/category/faith/foundations/">Faith</a></li>
<li id="menu-item-8387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8387"><a href="http://www.thecompassnews.org/category/columnists/editorials/">Editorials</a></li>
<li id="menu-item-8340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8340"><a href="http://www.thecompassnews.org/category/features/your-catholic-neighbor-s8-features/">Your Catholic Neighbor</a></li>
<li id="menu-item-8385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8385"><a href="http://www.thecompassnews.org/2014/04/mass-schedules-2/">Mass Schedule</a></li>
<li id="menu-item-8383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8383"><a href="http://www.thecompassnews.org/category/compassblog/">Blog</a></li>
</ul></div> <div class="clear"></div>
<p class="footer_text">
Copyright &copy; 2017 The Compass News, Inc. All rights reserved.<br/>
Reproduction of material from this website without written permission is strictly prohibited.
</p>
</div> 
</div> 
</div> 
</div> 
</div> 
<div class="container subfooter">
<div class="row" style="padding-right: 0; padding-left: 0;">
<div class="col_12">
<p>Site Development: <a href="http://www.hyperdo.com">Hyperdo Media</a></p>
</div> 
</div> 
</div> 
<script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'thecompassnews';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uberMenuSettings = {"speed":"300","trigger":"hoverIntent","orientation":"horizontal","transition":"slide","hoverInterval":"20","hoverTimeout":"400","removeConflicts":"on","autoAlign":"off","noconflict":"off","fullWidthSubs":"off","androidClick":"off","windowsClick":"on","iOScloseButton":"on","loadGoogleMaps":"off","repositionOnLoad":"off"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-content/plugins/ubermenu/core/js/ubermenu.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201706'></script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-content/plugins/uBillboard/js/billboard.min.js?ver=3.5.2'></script>
<script type='text/javascript' src='http://www.thecompassnews.org/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201706.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'95945329',post:'28957',tz:'-6',srv:'www.thecompassnews.org'} ]);
	_stq.push([ 'clickTrackerInit', '95945329', '28957' ]);
</script>
</body>
</html>